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Licence Terms - PCSpectra
PCSpectra supplied with the Elliott Instruments CCDSPEC spectrometer has a single user
licence and must not be copied or distributed.
A multi-user licence for Universities, Schools, etc is available from Andy Ray Developments.
Licence Terms - The PCS Image File Conversion Suite
PCSpectra uses the Andy Ray Developments PCS Image File Conversion Suite for reading
and writing data files in the bmp, fits and pgm formats.
The PCS Image File Conversion Suite can be downloaded from the Andy Ray
Developments website, http://www.andyraydevelopments.co.uk.
The PCS Image File Conversion Suite is free software. It can be redistributed and/or
modified under the terms of the GNU General Public License as published by the Free
Software Foundation, either version 3 of the License, or any later version.
The PCS Image File Conversion Suite is distributed in the hope that it will be useful, but
WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License for more
details.
The GNU General Public License is included with The PCS Image File Conversion Suite.
Alternatively, see http://www.gnu.org/licenses/.
The PCS Image File Conversion Suite uses the CFITSIO library of routines for reading and
writing data files in the FITS (Flexible Image Transport System) data format.
The CFITSIO Copyright, Disclaimer and Gnu General Public License is included with the
PCS Image File Conversion Suite. Alternatively, see http://heasarc.gsfc.nasa.gov/fitsio/ and
http://www.gnu.org/licenses
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Introduction to the PCSpectra Reference Manual
PCSpectra was written by Andy Ray Developments for analysing spectra from the Elliott
Instruments CCDSPEC spectrometer and can analyse images of up to 6144 pixels wide by
4096 pixels high.
It can:
load the image from a bmp, fits or pgm format file;
save the image in a bmp, fits or pgm format file;
save the displayed image in a bmp, fits or pgm format file;
print the displayed image;
set the initial display thresholds as % values;
close the image;
show the X and Y co-ordinates, the Wavelength (if a SpecCal.txt file exists) and the
Intensity of the image. Additionally, show the Greyscale value of the displayed
image.
display information about the image;
change the size of the displayed image;
invert the displayed image;
set the display thresholds as % or absolute values;
save and load the display settings;
invert the image (not the same as invert the displayed image - useful for identifying
absorption lines);
define one or two regions of interest for analysis using the mouse;
set or adjust the size and position of the regions of interest;
display the Spectrum (X Axis Projection) of the region of interest of the image;
save the displayed Spectrum in a bmp, fits or pgm format file
or
save the displayed Spectrum as data in a csv format file;
print the displayed Spectrum;
choose the X Scale (horizontal scale - Pixel or Wavelength);
choose the Y Scale (vertical scale - Mean or Sum);
choose the Limits (vertical scale - Manual or Auto).
display the Profile (Y Axis Projection) of the region of interest of the image;
save the displayed Profile in a bmp, fits or pgm format file
or
save the displayed Profile as data in a csv format file;
print the displayed Profile;
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choose the Y Scale (vertical scale - Mean or Sum);
choose the Limits (vertical scale - Manual or Auto).
calculate and display the centroid and the number of pixels above the threshold
value for the region of interest;
display the region of interest;
save the region of interest in a bmp, fits or pgm format file
or
save the displayed region of interest in a bmp, fits or pgm format file;
print the displayed region of interest;
change the size of the displayed region of interest;
invert the displayed region of interest image.
display the histogram (intensity distribution) for the region of interest;
save the displayed histogram in bmp, fits or pgm file format
or
save the displayed histogram as data in a csv format file; print the displayed
histogram;
choose the Y Scale (vertical scale - Lin or Log);
choose the displayed Thresholds (Data or Display).
save and load the analysis settings;
display information about the program.
Installation
PCSpectra is supplied on the CCDSPEC CD-ROM. Open the PCSpectra folder and double
click on setup.exe. This installs the software in the C:\Program Files\Andy Ray
Developments\PCSpectra folder.
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Using PCSpectra
Select Start->Programs->PCSpectra->PCSpectra

The File Menu

Loading the Image
Select File->Open to use the standard Open dialogue to load the image from a bmp, fits
or pgm format file.

If a SpecCal.txt calibration text file is present in the same folder as the image file a
pixel to wavelength calibration is carried out. The text file must contain the zero point
and scale factor constants on one line separated by a comma. For example: 50.0, 0.6
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Saving the Image

Select File->Save As->Image to use the standard Save As dialogue to save an image to a
bmp, fits or pgm format file.
An image in one file format can be loaded with File->Open and saved in another file
format with File->Save As->Image.
Select File->Save As->Display to use the standard Save As dialogue to save the displayed
image in a bmp, fits or pgm format file
Note that the displayed image saved using File->Save As->Display is not the same as the
image saved using File->Save As->Image. The displayed image includes the effects of
setting the lower and upper thresholds and inverting the display.
Printing the Displayed Image
Select File->Print
Setting the Initial Display Thresholds
Select File->Set Initial Display Thresholds

The lower threshold is set such that the specified % of pixels is below it.
The upper threshold is set such that the specified % of pixels is above it.
When an image is loaded, all pixels with intensity less than the lower threshold are
displayed as black and all pixels with intensity greater than the upper threshold are
displayed as white. This is useful when loading an image with a low contrast.
Closing the Image
Select File->Close to close the image and clear the display.
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Exiting PCSpectra
Select File->Exit
Displaying Values
When the pointer moves over the display the X and Y co-ordinates, the Wavelength (if the
SpecCal.txt file exists) and the Intensity of the image are shown. Additionally, the Greyscale
value of the displayed image is shown.
The Image Menu

Displaying Information about the Image
Select Image->Information
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Changing the Size of the Displayed Image
Select Image->Zoom->Zoom In, Zoom Out ... or Custom to change the size of the displayed
image. The Fit to Width option is particularly useful for spectra.

Inverting the Displayed Image
Select Image->Invert Display
Setting the Display Thresholds

Setting the Display Thresholds As % Values
Select Image->Set Display Thresholds->As % Values

The lower threshold is set such that the specified % of pixels is below it. The upper threshold
is set such that the specified % of pixels is above it.
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All pixels with intensity less than the lower threshold are displayed as black and all pixels
with intensity greater than the upper threshold are displayed as white.
Setting the Display Thresholds As Absolute Values
Select Image->Set Display Thresholds->As Absolute Values

The lower threshold must be set to a value between the minimum and the upper threshold.
The upper threshold must be set to a value between the maximum and the lower threshold.

All pixels with intensity less than the lower threshold are displayed as black and all pixels
with intensity greater than the upper threshold are displayed as white.
Saving and Loading the Display Settings

The display settings are the size, thresholds and whether the display is inverted.
Select Image->Display Settings->Save As to save
Select Image->Display Settings->Open to load
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The Analysis Menu

Displaying the SPECTRUM (X Axis Projection)
Select Analysis->SPECTRUM (X Axis Projection) to display the mean or sum of the
intensity values over the height (Y) for each width (X) of the region of interest of the
image.

The X co-ordinate (Wavelength or Pixel) and mean or sum of the intensity value are shown
as the cursor is moved over the display.
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Saving the SPECTRUM (X Axis Projection)

Select File->Save As->Display to use the standard Save As dialogue to save the
displayed Spectrum in a bmp, fits or pgm format file. The saved display can be used
in reports.
Select File->Save As->Values to use the standard Save As dialogue to save the
displayed Spectrum as data in a csv format file. The saved data can be read into a
spreadsheet.

Printing the SPECTRUM (X Axis Projection)
Select File->Print
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Changing the X Scale of the SPECTRUM (X Axis Projection) Display to Pixel or
Wavelength

Select Options->X Scale->Pixel
or
Select Options->X Scale->Wavelength
Changing the Y Scale of the SPECTRUM (X Axis Projection) Display to Mean or Sum

Select Options->Y Scale->Mean
or
Select Options->Y Scale->Sum
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Changing the Y Scale Limits of the SPECTRUM (X Axis Projection) Display to Manual
or Auto

Select Options->Y Scale->Limits->Manual to change the lower and upper limits to Manual
and enter the lower and upper limits
or
Select Options->Y Scale->Limits->Auto to change the lower and upper limits to Auto (ie
between the minimum and maximum intensities of the image)
Displaying the PROFILE (Y Axis Projection)
Select Analysis->PROFILE (Y Axis Projection) displays the mean or sum of the intensity
values over the width (X) for each height (Y) of the region of interest of the image.

The Y co-ordinate (Pixel) and mean or sum of the intensity values are shown as the
cursor is moved over the display.
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Saving the PROFILE (Y Axis Projection)

Select File->Save As->Display to use the standard Save As dialogue to save the displayed
Profile in a bmp, fits or pgm format file. The saved display can be used in reports.
Select File->Save As->Values to use the standard Save As dialogue to save the displayed
Profile as data in a csv format file. The saved data can be read into a spreadsheet.
Printing the PROFILE (Y Axis Projection)
Select File->Print
Changing the Y Scale (Vertical Scale) of the PROFILE (Y Axis Projection) Display to
Mean or Sum

Select Options->Y Scale->Mean
or
Select Options->Y Scale->Sum
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Changing the Y Scale (Vertical Scale) Limits of the PROFILE (Y Axis Projection)
Display to Manual or Auto

Select Options->Y Scale->Limits->Manual to change the lower and upper limits to
Manual and enter the lower and upper limits
or
Select Options->Y Scale->Limits->Auto to change the lower and upper limits to Auto (ie
between the minimum and maximum intensities of the image)
Displaying the Centroid and Area Measurement
Select Analysis->Centroid and Area Measurement to calculate and display the centroid
and the number of pixels with intensities above the threshold value in the region of
interest.

Inverting the Image
Select Analysis->Invert (Maximum - Intensity)
Inverting the image enables the centroid of an absorption line to be determined.
Note that inverting the image using Analysis->Invert (Maximum - Intensity) is not the same
as inverting the display using Image->Invert Display. Inverting the image inverts each
intensity value by subtracting it from the maximum intensity value and the modified value is
used in subsequent analysis. Inverting the display only changes the visual appearance of
the display and has no effect on the intensity value.
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Setting the Data Thresholds
Select Analysis->Set Data Thresholds to set the data thresholds.

The lower threshold must be set to a value between the minimum and the upper threshold.
The upper threshold must be set to a value between the maximum and the lower threshold.
All pixels with intensity less than the lower threshold and all pixels with intensity greater
than the upper threshold are excluded in subsequent analysis.
Note that setting the data thresholds is not the same as setting the display thresholds.
Setting the data thresholds excludes pixels in subsequent analysis. Setting the display
thresholds only changes the visual appearance of the display and has no effect on the
subsequent analysis.
Using the Mouse to Define Regions of Interest for Analysis
To define the first region of interest depress the left hand mouse button in one corner of the
region, move the pointer to the diagonally opposite corner and release the button. The first
region is marked by a blue rectangle. To define a second region of interest depress the shift
key and depress and release the left hand mouse button in the top left hand corner of the
region. The second region is also marked by a blue rectangle.
Setting or Adjusting the Size and Position of the Regions of Interest
Select Analysis->Setting the Regions of Interest Size and Position
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In addition to setting or adjusting the size and position of the regions of interest the display
of the mean or sum for projections can be selected and, when regions of interest have been
set, the operation, subtraction or addition, can be selected. If the SpecCal.txt file exists the
X units, pixel or wavelength, can be selected
If the first region of interest contains the spectrum and the second region of interest
contains the background, selection of RoI 1 – RoI 2 removes the background from the
spectrum.
Displaying the Region of Interest
Select Analysis->Display Region of Interest

Saving the Region of Interest

Select File->Save As->Image to use the standard Save As dialogue to save the region of
interest in a bmp, fits or pgm format file. The saved image can be used in further analysis.
Select File->Save As->Display to use the standard Save As dialogue to save the displayed
region of interest in a bmp, fits or pgm format file. The saved display can be included in
reports.
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Note that the display saved using File->Save As->Display is not the same as the image
saved using File->Save As->Image. The display includes the effects of setting the lower
and upper thresholds and inverting the display.
Printing the Displayed Region of Interest Image
Select File->Print
Changing the Size of the Region of Interest Display
Select Image->Zoom->Zoom In, Zoom Out ... or Custom to change the size of the display.
The Fit to Width option is particularly useful.

Inverting the Region of Interest Display
Select Image->Invert Display
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Displaying the Histogram (Intensity Distribution) for the Region of Interest
Select Analysis->Histogram (Intensity Distribution)

The Histogram (Intensity Distribution) shows the distribution of intensity (brightness) in the
image to assist in setting display and data thresholds.
Saving the Histogram (Intensity Distribution) for the Region of Interest

Select File->Save As->Display to use the standard Save As dialogue to save the
displayed histogram in bmp, fits or pgm file format. The saved display can be used in
reports.
Select File->Save As->Values to use the standard Save As dialogue to save the displayed
histogram as data in a csv format file. The saved data can be read into a spreadsheet.
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Printing the Histogram (Intensity Distribution)
Select File->Print
Changing the Type of Y Scale (vertical scale - Lin or Log) Displayed

Select Options->Y Scale->Lin
or
Select Options->Y Scale->Lin
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Changing the Type of Threshold (Data or Display) Displayed

Select Options->Thresholds->Data
or
Select Options->Thresholds->Display
Saving and Loading the Analysis Settings

The analysis settings are the size and position of the regions of interest and the choices
of the mean or sum, subtraction or addition, pixel or wavelength and data thresholds.
Select Analysis->Analysis Settings->Save As
or
Select Analysis->Analysis Settings ->Open
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The ability to save and load the analysis settings enables the same regions of interest and
choices of the mean or sum, subtraction or addition, pixel or wavelength and data thresholds
to be used for every image in a set of spectra taken with the same setup making comparison
easy.
The Help Menu
Select Help->About to display information about PCSpectra
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